Scheduled Maintenance
Resolved
Jan 08, 2026 at 09:14pm UTC
Our systems are back online!
Affected services
Updated
Jan 08, 2026 at 08:50pm UTC
Our updates are taking longer than expected. Queries can't be processed during this time.
Affected services
Created
Jan 08, 2026 at 08:10pm UTC
We're updating our systems on the query server, so individual queries might time out occasionally.
Affected services