Data Duplication Incident
Updated
Mar 25, 2026 at 05:10pm UTC
Backups are being installed successfully. Most customers should have their clean data back by now, we're working on some stragglers.
Affected services
Updated
Mar 25, 2026 at 01:17pm UTC
We've begun replaying backups for affected customers.
Affected services
Updated
Mar 25, 2026 at 11:24am UTC
The affected time range is March 16 through March 24, and we've identified affected namespaces. We'll start reloading those customers from backup after some additional checks.
Affected services
Created
Mar 25, 2026 at 10:07am UTC
We're investigating reports of duplicated events for some or all customers. The affected time range seems to be the last 7 days. We're exploring restoring that data from backups.
Affected services