Back to overview
Downtime

Dashboard Issue

Apr 20, 2026 at 7:43pm UTC
Affected services
Query Service
Metadata Storage
Global Dataset, default properties
Global Dataset, all properties
Namespaced Datasets

Resolved
Apr 20, 2026 at 8:35pm UTC

We'r marking the issue as resolved but will continue monitoring.

Updated
Apr 20, 2026 at 8:25pm UTC

Our network is back up, but we're continuing to monitor the situation.

Created
Apr 20, 2026 at 7:43pm UTC

We're experiencing a problem with our network backbone that is resulting in flaky connectivity an errors in the query API. We're investigating.