Back to overview
Maintenance

Infrastructure Update

Jun 15, 2026 at 7:15am UTC  –  Jun 15, 2026 at 7:53am UTC
Affected services
Query Service
Metadata Storage
Namespaced Datasets

Resolved
Jun 15, 2026 at 7:53am UTC

And we're fully back! Thanks for your patience <3

Updated
Jun 15, 2026 at 7:53am UTC

Maintenance ended

Created
Jun 15, 2026 at 7:15am UTC

We're updating our infrastructure. Please allow for some delays or failed queries.