Back to overview
Resolved

Older Data Temporarily Unavailable

Jul 13, 2026 at 9:23am UTC
Affected services
Query Service

Resolved
Jul 13, 2026 at 11:58am UTC

All back online!

Created
Jul 13, 2026 at 9:23am UTC

We're working on the servers that hold data from between 24 months ago and 3 months ago. Data in that time period will not be available for queries during that time. Thanks for your understanding. No data is lost.