Back to overview
Resolved
Older data temporarily unavailable
Jul 20, 2026 at 7:36am UTC
Affected services
Query Service
Resolved
Jul 20, 2026 at 8:59am UTC
We've fixed the issue and added more monitoring to prevent this from happening in the future!
Affected services
Created
Jul 20, 2026 at 7:36am UTC
We're working on the servers that hold data from between 24 months ago and 3 months ago. Data in that time period will not be available for queries during that time. Thanks for your understanding. No data is lost.
Affected services