Back to overview
Resolved

Queries not working

Jul 21, 2026 at 9:27pm UTC
Affected services
Query Service
Current Data in Namespaces
Long-Term Data in Namespaces

Resolved
Jul 21, 2026 at 9:46pm UTC

All back online, all data is available, ingestion has not been affected, and data processing has caught up.

Updated
Jul 21, 2026 at 9:38pm UTC

Current Data Stores have recovered, still waiting on long-term stores.

Ingestion was unaffected, but processing incoming data is delayed slightly.

Updated
Jul 21, 2026 at 9:37pm UTC

We've found the issue and deployed a fix. It seems our clusters are recovering... standing by.

Created
Jul 21, 2026 at 9:27pm UTC

We're investigating an issue with queries failing. Data ingestion is not affected and all data is safe.